Lỗi no package khi cài phpmyadmin

Thảo luận trong 'Hỗ trợ tên miền, hosting, máy chủ' bắt đầu bởi hoangsuu, 4/6/15.

  1. hoangsuu

    hoangsuu Well-Known Member

    Bài viết:
    142
    Đã thích:
    75
    Trong quá trình setup vps, cụ thể là setup phpMyAdmin mình hay gặp phải lỗi no package. Thực ra, lỗi này chỉ là bạn cần phải cập nhật gói yum tương ứng với operating system (mình hay sử dụng centos 6 x64).

    Đầu tiên, bạn cần install gói wget trước (nếu đã có rồi thì bỏ qua) bằng lệnh:
    PHP:
    sudo yum install wget
    Sau đó các bạn truy cập vào link bên dưới và tải về package phù hợp với OS các bạn đang sử dụng nhé!
    PHP:
    http://packages.sw.be/rpmforge-release/
    Ví dụ của mình là Centos 6 x64 thì mình sẽ get gói mới nhất hiện tại với cú pháp command line:
    PHP:
    wget http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
    Sau đó, các bạn cài đặt nó:
    PHP:
    rpm -Uhv rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
    Tiếp theo, hãy update yum với cú pháp:
    PHP:
    yum update
    Và bắt đầu cài đặt phpMyAdmin với cú pháp:
    PHP:
    yum install phpmyadmin
    Việc còn lại là cấu hình phpmyadmin. Mình cũng mong các bạn lưu tâm là: "để đảm bảo an toàn cho database, sau khi sử dụng phpmyadmin nên stop nó bằng cách đóng port hoặc cấu hình file phpmyadmin.conf chỉ chấp nhận truy cập local."
     
    Đang tải...
    Bluesky thích bài này.
Đang tải...
Đang tải...